Personnaliser le favicon [Résolu]

Bonsoir à tous,

J’ai voulu personnaliser le favicon de mon wiki en modifiant le fichier /TiddlyWiki/upgrade.html ainsi :

<!--~~ <link id="faviconLink" rel="shortcut icon" href="favicon.ico">~~-->
<link id="faviconLink" rel="shortcut icon" href="/documents/icones/jt.png">

Sur le moment, c’était bon. Mais ensuite, à la première modif de mon wiki, c’est le favicon par défaut qui revient.

Où puis-je modifier ce favicon pour que cela soit pérenne ?

Bonjour @joel
Pour la favicon, c’est plutôt en important un fichier image (ou même SVG), que tu renomme ensuite en $:/favicon.ico

(modifier directement le fichier HTML est plutôt à éviter).

Bonjour @sylvain, et merci,

OK, mais dans quel dossier l’importer ?
Parce que, dans mon dossier /TiddlyWiki/, j’ai des dizaines de favicon.ico, et aucun ne correspond à ce qui s’affiche dans l’onglet de mon navigateur…

OK

Dans TiddlyWiki directement :sweat_smile:
Tu glisse et dépose ta favicon pour l’importer quand tu consultes ton TW via ton navigateur.

J’aurai jamais pensé que l’on puisse faire comme ça.

Par contre, ça ne marche pas.

La manip a créé un nouveau tiddler :
$:/Import

Les tiddlers suivants ont été importés :

    favicon.ico

Si je clique dessus, le tiddler favicon.ico affiche mon favicon, mais par contre ça ne change rien dans l’affichage de l’onglet de Firefox…

Et si je raffraîchit la page, le tiddler favicon.ico disparaît…

On avance :wink:
Tu avais un bouton pour valider l’importation et valider la création du tiddler image.
Ensuite il faudra que tu édite le tiddler précédemment créé comme indiqué au début.

J’ai relu et tu as bien importé. Il te reste à l’éditer et le renommer comme je l’indiquais.
Soit avant favicon.ico en $:/favicon.ico

Je l’ai fait, mais ça n’as rien changé.

Du coup, j’ai essayé de renommer $:/favicon.ico avant l’importation, ce qui donne toujours le même résultat :

Après avoir cliqué « Importer » :

Résultat :

Mais ça ne change toujours rien dans l’affichage de l’onglet de Firefox :

Sur ta capture le $:/ de la favicon ne ressort pas pareil que la CSS pour les tiddlers système en gris. C’est bien les mêmes caractères ?
Je t’aide de mémoire depuis le début, mais tu as aussi peut être un type de tiddler de défini qui empêche de correctement voir le résultat.

En fait, je viens de m’apercevoir, ou ouvrant le volet de droite, que le tiddler $:/favicon.ico était devenu $:favicon.ico : il avait perdu le slash…
Bizarre, bizarre…
En le rajoutant, c’est tout bon.
Merci beaucoup pour ton aide @sylvain

1 J'aime