Noteself, CouchDB


#1

Bonjour à tous ! :slight_smile:
J’essaie de configurer depuis quelque temps la synchronisation entre Noteself se trouvant sur mon téléphone et un serveur couchDB installé sur mon PC Windows. Il y a bien un tuto sur le site de Noteself traitant la configuration avec IBM cloudant, mais pas pour une utilisation avec couchDB.

Pour l’instant j’en suis là :
1-Créer un utilisateur
2-Créer une database nommée “tiddlywiki”


3-Ensuite j’ai attaché le fichier empty.html de Noteself

Et ensuite je suis perdu, je ne sais pas quelle adresse il faut écrire dans Noteself, et je ne sais même pas si je fais bien les choses dans couchDB…:roll_eyes:

Quelqu’un connait le sujet ??? :wink:


#2

Pour celles et ceux qui découvre le projet de Danielo : https://noteself.github.io/

La question m’interesse :slight_smile: Noteself fonctionnant plutôt bien sur smartphone, je n’y suis jamais vraiment passé pour la question de récupérer une sauvegarde des données.

Pour l’URL, j’imagine que c’est l’URL de ton instance sur ton réseau local.

Je ne connaissait pas Fauxton, à l’occasion il faudra que je regarde (http://couchdb.apache.org/fauxton-visual-guide/.

Je maîtrise pas Noteself, mais je me demande pourquoi l’étape 3. Le fait de configurer l’URL de ton serveur CouchDB et son identifiant devrait suffire pour répliquer la base de données non ?


#3

Ce soir j’ai avancé sur le sujet !
1-Sur windows, dans l’interface Fauxton de couchDB j’ai créé un utilisateur admin avec mot de passe
2-J’ai créé une database nommé “tw”.
3-Dans les paramètres de Fauxton j’ai activé CORS (comme expliqué dans FAQ du site de noteself)
4-Sur le même PC dans mon tiddlywiki noteself j’ai rentré les paramètres suivants :

CouchDB URL:
http://127.0.0.1:5984/

Nom de la base de données distante
tw

5-Ensuite j’ai cliqué sur “online” pour entrer le nom d’utilisateur et le mot de passe

et cela fonctionne !!! :grinning:

Mais pas sur un autre pc sur le même réseau wifi :disappointed_relieved:

Normal me direz-vous il n’a pas entré l’adresse ip du PC serveur. Et bah si, mais… non…a pas marché… :angry:

PS : Et oui Sylvain, tu as raison l’étape 3 n’était pas utile…


#4

C’est rigolo de voir les enregistrements des tiddlers :slight_smile:

Pour le moment je bloque aussi pour l’accès en local depuis un autre périphérique.
C’est logique par défaut puisque dans les options bind_address pointe sur 127.0.0.1

Une piste :

A mettre à jour jour selon l’emplacement de son installation (j’ai laissé par défaut sous C:\CouchDB\etc, et j’ai l’impression que l’on peut le faire depuis l’admin de Fauxton. J’arrive à minima sur le poste à accéder depuis mon IP locale (en mettant donc 0.0.0.0 et sur le deuxième port en http 5986 au lieu de 5984), mais toujours pas de mon mobile. J’ai pas vraiment trouvé comment redémarrer CouchDB sous Windows, c’est peut-être pour ça.


#5

Bon c’était logique, mais comme je n’utilise plus WIndows, il m’a fallu retrouver où gérer le pare-feu.

J’ai rajouté le port 5986, et bingo j’accède depuis mon téléphone à l’interface d’admin de Fauxton :sunglasses:

J’ai ainsi réussi depuis mon mobile à m’authentifier depuis Noteself. Et sur mon TW en local, j’ai même pu récupérer le contenu que j’avais créé sur mon téléphone.
(par contre pour l’instant je n’arrive pas à récupérer ce que j’avais commencé à mettre sur le Noteself du PC pour le synchroniser avec le mobile) ==> ah si en fait, c’est juste que cela n’a pas été immédiat. Plutôt cool !


#6

Le pare-feu !!! :roll_eyes:

Bon le problème c’est que ça ne fonctionne toujours pas chez moi. Ça fonctionne que sur le PC serveur. Voiçi ce que j’ai essayé :

Sur le serveur :

  • Activer CORS avec option All domains ( * )
  • chttpd > bind_address = 127.0.0.1
  • chttpd > bind_address = 192.168.1.17
  • chttpd > port = 8080
  • httpd > bind_adress = 0.0.0.0
  • Ajouter les ports 5984 et 5986 au pare-feu windows
  • Désactiver le pare-feu windows (:upside_down_face:…)

Dans noteself :

Impossible de me connecter… :weary:

Il doit y avoir un problème avec mon PC non ? (Windows 10)


#7

Je n’avais pas modifié le port du chttpd, mais je l’avais aussi mis en 0.0.0.0 (et aussi dans httpd).
Sur Noteself, l’adresse local (en précisant l’URL complète, soit http://192.168.1.19:5986).

Est-ce qu’en local déjà tu arrive à ouvrir ton adresse http://192.168.1.17:5986 ou http://192.168.1.17:5984 en jouant avec la bind_adress en mode passoire 0.0.0.0 ?


#8

Oui j’avais aussi essayé ces possibilités. Ce que j’ai oublié de préciser c’est qu’en local tous fonctionne dans NoteSelf, même l’adresse 197.168.1.17 si je la configure. Sur le PC distant j’arrive juste à accéder à Fauxton. Mais NoteSelf ne veux rien savoir, je comprend pas pouvoir accéder à l’interface Fauxton mais pas à NoteSelf car ça veux bien dire que le Pare-feu m’autorise.

Est-ce que tu peux décrire à nouveau les étapes que tu as effectué stp ?


#9

Ah bah si tu arrive bien à accéder depuis une autre poste à Fauxton, c’est en effet que la porte est ouverte et CouchDB en écoute sur l’extérieur.
Donc je n’ai pas vraiment d’autres conseils à te donner.

Ton Noteself il est sur un téléphone ou c’est depuis un autre PC que tu essaye ? Sinon tu pourrais voir avec un nouveau fichier qui n’a jamais eu de paramètre d’authentification pour voir.


#10

Très bonne suggestion Sylvain ! Car effectivement sur le PC distant cela fonctionne avec un fichier NoteSelf stocké en local. Par contre malgré les ports ouvert sur mon PC serveur, si j’active le Pare-feu, tout cela ne fonctionne plus.

Pour l’instant j’abandonne cette solution de synchronisation, car possédant un téléphone Windows phone 8.1 un peu trop vieux, NoteSelf se bloque lorsque je lui rentre une adresse CouchDB.

En tous cas merci beaucoup Sylvain !!! :slightly_smiling_face: