Gallerie d'image ne forme pas une grille


#1

hey,

J’ai un probleme avec la fonction gallerie d’image qui ne veux pas former une grille comme vue ici

J’ai crée un exemple ici
Le code se trouve sous "structurestab"
Il faudrait que les images se suivent de gauche à droite jusqu’à devoir retourner à la ligne or elles se suivent de haut en bas sans jamais former une grille:


J’ai un autre probleme avec mon code. Il n’arrive pas à lire les listes. il lira “[[1]] [[2]] [[3]]” comme un seul tiddler à chercher…


#2

Bonne question, j’ai essayé de regarder, mais le problème avec un float c’est de désactiver son effet indésirable sur le positionnement/chevauchement qui a alors lieu…


#3

Je viens de voir ton post sur la liste de fin août.

Juste avant, j’arrivais juste à le faire sur les images en enlevant la référence au lien vers le tiddler correspondant, en faisant le ménage pour juste afficher les images donc.

Sur le fil Mark a pu te mettre le code pour lier les images vers les tiddlers, manque plus que le libellé associé à afficher juste en dessous… C’est pas gagné :wink:


#4

Bonsoir @Aknar,

Est-ce que l’exemple du jour de Jed pourrait répondre à ta problématique, avec l’utilisation de la propriété display:inline-flex :

<div style='text-align:center'>
<$list filter='[all[shadows]prefix[$:/core/images/]]'>
<div style='display:inline-flex;text-align:center;'>
<$link to=<<currentTiddler>>><$transclude/><br><$list filter='[<currentTiddler>removeprefix[$:/core/images/]]'><$view field='title'/></$list></$link>
<br>
</div>
</$list>
</div>