Démarrage automatique de TW5 sur Node.js


#1

Bonjour à tous.
J’héberge TW5 sur Node.js qui est installé sur la distribution Diet-pi sur mon Raspberry pi. Cela fonctionne très bien. Mon seul soucis est qu’au redémarrage du Raspberry pi, mon TW5 ne ce lance pas automatiquement :frowning:

J’ai cherché sur d’autre forum, par exemple ici :
https://groups.google.com/forum/#!msg/TiddlyWiki/34EdjJFYIgQ/ArTGk6EGoK8J
et ici :
http://tiddlywiki.narkive.com/pSmlDlFU/tw-tw5-node-js-install-launching-tiddlywiki-server-on-startup
mais je ne comprend pas bien c’est méthode.
Y’a pas plus simple ??? :grin:


#2

Bonsoir @Djodo

Ton deuxième lien c’est le même fil de discussion :wink:

Et bien il y a plusieurs pistes de le fil, le dernier avec une tâche cron est sans doute le plus simple j’imagine.

Si tu utilise la commande crontab -e on rentre dans l 'écriture du fichier, avec visiblement l’éditeur vi (faut en effet avoir les bases pour correctement enregistrer).

Et il propose donc d’y mettre une tâche @reboot qui lancera alors le serveur TW.

@reboot configures a job to run once when the daemon is started. Since cron is typically never restarted, this typically corresponds to the machine being booted.

Il faut moi-aussi que je me remette un RaspberryPi depuis mon déménagement, je garde ça sous le coude pour le tester.


#3

J’avais testé avec Cron, mais je ne sais pas pourquoi cela n’a pas fonctionné… Mais aujourd’hui j’ai réussi à résoudre ce problème ! :grinning:

Dans la version 150 de Diet-pi, les développeurs on ajoutés une option dans le menu “dietpi-autostart”, qui permet de lancer des commandes personnalisé au démarrage du Raspberry Pi.

1-se connecter en ssh
2-taper la commande : dietpi-autostart
3-activer l’option commande personnaliser
4-ajouter par vous même les commande personnalisé de TW5 dans le fichier/etc/dietpi/autostart.sh

Voir ici :


#4

Bon c’est le principal si tu as réussi à trouver une solution sur mesure :slight_smile:


#5

J’essaie de lancer TW5 avec cron, comme précédemment énoncé, pour une autre machine. Mais TW5 ce lance d’une façon étrange (voir photo). Quelqu’un sait pourquoi ?


#6

Salut,

Je ne pense pas que ça est un lien avec la tâche Cron, c’est plutôt la CSS qui ne doit pas aller :

ControlPanel > Appareance > Theme Tweaks > Sizes

Et voici les paramètres par défaut :

A bientôt :wink:


#7

J’ai vérifié les paramètres d’apparence et en faite je me suis aperçut qu’il n’y avait même pas de plugins d’apparence d’installé :open_mouth:. J’ai essayé de l’installer mais ça ne fonctionne pas. Cela me dépasse, c’était un test sur Orange Pi mais je croit que je vais rester sur Raspberry Pi pour ce genre de chose. Merci ! :slight_smile: